Entwicklungsumgebung

Alles für Entwickler: Java, JavaScript, REST-API, AngularJS, HTML.

Moderators: MZ per X, gene

Entwicklungsumgebung

Postby Hammer » 27 Nov 2012, 16:06

Ich hab gestern abend mal kurz versucht, die Entwicklungsumgebung aufzusetzen und das Beispiel auszuprobieren und hatte leider einige Fehler im Workspace. Hatte leider auch zu wenig Zeit, um dem Ganzen noch auf die Schliche zu kommen, deswegen frag ich jetzt einfach mal:
- Welche Java-Version verwendet ihr?
- Welches Eclipse? (ich hab Helios)
- Irgendwelche Einstellungen, die man noch machen muss?
Die benötigten Jars wurden von Maven scheinbar alle richtig rangezogen, das funktioniert also alles.

Das mit den Versionen sollte mMn noch in die Anleitung mit rein.
Unabhängig von den Fehlern im Workspace funktionierte das Beispiel dann aber doch.
(Fehlermeldungen weiß ich grad nicht mehr und hab sie auch nicht vor mir liegen, kann sie aber noch später nachliefern...)
Hammer
 
Posts: 5
Joined: 22 Nov 2012, 14:56

Re: Entwicklungsumgebung

Postby gene » 27 Nov 2012, 18:10

Zwischenfrage:
Bist du nach dieser Anleitung vorgegangen?
The creator of Kultpower.de
Co-founder of Oregami.org
User avatar
gene
 
Posts: 997
Joined: 25 Jan 2001, 21:20
Location: Münster

Re: Entwicklungsumgebung

Postby Hammer » 27 Nov 2012, 21:51

Ja, hab die Anleitung befolgt.
Eine der Fehlermeldungen, die ich bekomme ist z.B.:
Code: Select all
javax.servlet cannot be resolved to a type
in den jsp-Dateien.
Ich vermute, dass da mein Classpath nicht ganz richtig ist... ich recherchiere demnächst mal... 8)
Hammer
 
Posts: 5
Joined: 22 Nov 2012, 14:56

Re: Entwicklungsumgebung

Postby gene » 29 Nov 2012, 20:24

Ich verwende Eclipse "Indigo" 3.7 und Java 1.6 und habe damit keine Probleme.

Kannst du genauer sagen, "wo" der von dir genannte Fehler angezeigt wird?

Teste gerade mal Eclipse "Juno" 4.2:
  • JEE-Version runterladen, entpacken und starten
  • m2e Maven Eclipse plugin installieren
  • per Konsole das Projekt auschecken
    Code: Select all
    git clone git@github.com:oregami/oregami.org.git /Users/meinUser/oregami.org
  • Eclipse: Import => Existing Maven project
  • Klasse "Start" als Java Application starten
  • http://localhost:8080 ansurfen
  • läuft fehlerfrei
The creator of Kultpower.de
Co-founder of Oregami.org
User avatar
gene
 
Posts: 997
Joined: 25 Jan 2001, 21:20
Location: Münster

Re: Entwicklungsumgebung

Postby StevenStorm » 14 Dec 2012, 00:07

Hast du in Eclipse das JDK eingestellt und nicht das JRE? :)
StevenStorm
 
Posts: 23
Joined: 26 Aug 2012, 16:04

Re: Entwicklungsumgebung

Postby Hammer » 22 Dec 2012, 21:37

Soo, jetzt bin ich nach langer Zeit mal wieder dazu gekommen das auszuprobieren...
und es funktioniert jetzt. Hab die aktuellste Eclipse-Version runtergeladen und auf das JDK umgestellt.
Werd mir in den nächsten Tagen (also nach Weihnachten... :wink: ) das Forum noch genauer ansehen und ein wenig mitdiskutieren.
Hammer
 
Posts: 5
Joined: 22 Nov 2012, 14:56

Re: Entwicklungsumgebung

Postby gene » 22 Dec 2012, 21:41

Hammer wrote:Werd mir in den nächsten Tagen (also nach Weihnachten... :wink: ) das Forum noch genauer ansehen und ein wenig mitdiskutieren.

Sehr gut! :D
The creator of Kultpower.de
Co-founder of Oregami.org
User avatar
gene
 
Posts: 997
Joined: 25 Jan 2001, 21:20
Location: Münster


Return to Technische Diskussionen (deutsch/german)

Who is online

Users browsing this forum: No registered users and 1 guest

cron